EIGRP auto and manual summarization

LinkedIn
Facebook
Facebook
Google+
https://netfixpro.com/eigrp-auto-and-manual-summarization/
RSS
Follow by Email

This article demonstrates the route summarization in EIGRP on Cisco IOS routers. EIGRP supports two types of route summarization. Auto summarization and manual summarization.

To best describe, I am using the simple topology of 3 IOS-based routers as shown in the above-mentioned diagram. R1-R2 are connected using Eth0/0 interfaces and R2-R3 are connected using their Eth0/1 interfaces. R1 and R3 have some loopback interfaces configured as shown in the diagram. Here are the initial configurations of all 3 routers.

Click here →

To view the initial configuration

R1

interface Loopback0
 ip address 10.10.10.1 255.255.255.0
!
interface Loopback1
 ip address 10.10.11.1 255.255.255.0
!
interface Ethernet0/0
 ip address 172.16.12.1 255.255.255.0
 no shutdown
!
router eigrp 100
 network 10.0.0.0
 network 172.16.0.0

R2

interface Ethernet0/0
 ip address 172.16.12.2 255.255.255.0
 no shutdown
!
interface Ethernet0/1
 ip address 172.16.23.2 255.255.255.0
 no shutdown
!
router eigrp 100
 network 172.16.0.0

R3

interface Loopback0
 ip address 10.10.13.1 255.255.255.0
!
interface Ethernet0/1
 ip address 172.16.23.3 255.255.255.0
 no shutdown
!
router eigrp 100
 network 10.0.0.0
 network 172.16.0.0

Auto-Summary

As the name implies when auto-summary is enabled, EIGRP automatically advertises classful summary routes to other EIGRP neighbors. As of IOS release 15.0, EIGRP auto-summary now defaults to disabled otherwise, it was enabled by default in prior IOS versions.

So how exactly it works?

When auto-summary is enabled, EIGRP checks for any directly connected interface subnets that fall within the range of your network command(s) and if so, routes are automatically summarized to their classful mask and EIGRP advertise the classful A, B or C network to its neighbors. NOTE: It will only summarize routes from subnets on its own interfaces, not the ones you learn from other routers. The result of this behavior is that EIGRP cannot support discontiguous major networks when auto-summarization is enabled, as seen in the reachability problems in this task.

To manually enable auto-summarization, configure the command auto-summary under the EIGRP routing process.

R1,R2,R3#
router eigrp 100
 auto-summary

Since auto-summary is enabled now, as shown in the diagram below R1 and R3 are advertising 10.0.0.0/8 (class A network) to R2 instead of advertising their /24, 10 dot network(s) as they cross the major subnet boundaries. This creates a problem for R2 as it will think it has two equal paths to reach 10.0.0.0/8, one through R1 and another through R3. This is called a discontiguous network situation.

eigrp-summerization-613x181

R2# show ip route eigrp | beg Gateway
Gateway of last resort is not set

D     10.0.0.0/8 [90/409600] via 172.16.23.3, 00:00:09, Ethernet0/1
                 [90/409600] via 172.16.12.1, 00:00:09, Ethernet0/0

Now let’s verify the reachability to loopback networks from R2. As you can see in the following output, some ping works and some doesn’t. This is because R2 has two equal cost summary route of 10.0.0.0/8 network.

R2#ping 10.10.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
UUUUU
Success rate is 0 percent (0/5)

R2#ping 10.10.11.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.11.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/5 ms

R2#ping 10.10.13.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.13.1, timeout is 2 seconds:
UUUUU
Success rate is 0 percent (0/5)

NOTE: R1 and R3 router also installs a local EIGRP summary route to Null0. The end result is that they cannot learn about each other’s summaries to 10.0.0.0/8, and reachability is not obtained between these networks as shown below.

R3# show ip route eigrp | beg Gateway
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
D        10.0.0.0/8 is a summary, 00:01:06, Null0
      172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
D        172.16.0.0/16 is a summary, 00:01:06, Null0
D        172.16.12.0/24 [90/307200] via 172.16.23.2, 00:01:03, Ethernet0/1
R3# ping 10.10.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
So how can you solve this problem?

Well, you have two options. Either you get rid of the discontiguous network from either router or disable the auto-summary. Ideally, you want to see most specific networks in the route table as you configure and advertise the networks using any dynamic routing protocol, not the classful summarized routes. Let’s disable the auto-summary everywhere and see the results.

R1,R2,R3#
router eigrp 100
 no auto-summary

Let’s verify the route-table and reachability now.

R2# show ip route eigrp | beg Gateway
Gateway of last resort is not set

      10.0.0.0/24 is subnetted, 3 subnets
D        10.10.10.0 [90/409600] via 172.16.12.1, 00:00:50, Ethernet0/0
D        10.10.11.0 [90/409600] via 172.16.12.1, 00:00:50, Ethernet0/0
D        10.10.13.0 [90/409600] via 172.16.23.3, 00:00:43, Ethernet0/1
R2#ping 10.10.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/5 ms

R2#ping 10.10.11.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.11.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/5 ms

R2#ping 10.10.13.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.13.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/4/5 ms
Manual Summarization

EIGRP supports manual summarization at the interface level using the ip summary-address eigrp command. It is very easy and good thing is, you can summarize anywhere in your network. From a design perspective, You want to summarize routes to both reduce the size of the routing table and to limit the scope of EIGRP query messages. When a summary is configured in EIGRP, all subnets that make up the summary are suppressed from being advertised out the link and only summarized network is advertised.

Now let’s configure manual summarization on R1 so it summerize networks 10.10.10.0/24 and 10.10.11.0/24 to a single summary network.

R1(config)# interface Ethernet0/0
R1(config-if)# ip summary-address eigrp 100 10.10.10.0 255.255.254.0

Let’s check the route table of R2 again. R2 is now only receiving the summary network 10.10.10.0/23 from R1 as expected.

R2#show ip route eigrp | beg Gateway
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D        10.10.10.0/23 [90/409600] via 172.16.12.1, 00:00:11, Ethernet0/0
D        10.10.13.0/24 [90/409600] via 172.16.23.3, 00:05:52, Ethernet0/1

Note When summaries are created in EIGRP, the router automatically installs a route to Null0 to match the summary. This is used to prevent the router from forwarding traffic for destinations inside the summary that it does not have a longer match for. However, in certain designs, this can be an undesirable behavior. To resolve this, EIGRP sets its interface-level summaries to have an administrative distance of 5 by default. Let’s verify the same on R1.

R1#show ip route eigrp | beg Gateway
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
D        10.10.10.0/23 is a summary, 00:12:56, Null0
D        10.10.13.0/24 [90/435200] via 172.16.12.2, 00:18:37, Ethernet0/0
      172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D        172.16.23.0/24 [90/307200] via 172.16.12.2, 00:31:24, Ethernet0/0
R1#show ip route 10.10.10.0 255.255.254.0
Routing entry for 10.10.10.0/23
  Known via "eigrp 100", distance 5, metric 128256, type internal
  Redistributing via eigrp 100
  Routing Descriptor Blocks:
  * directly connected, via Null0
      Route metric is 128256, traffic share count is 1
      Total delay is 5000 microseconds, minimum bandwidth is 8000000 Kbit
      Reliability 255/255, minimum MTU 1514 bytes
      Loading 1/255, Hops 0

Note that EIGRP summary route inherits metrics from its subnet with the best metric in use. If you change the best subnet metric means summary must be re-advertised again.

Let’s increase the bandwidth on Loopback0 interface of R1 and then verify the route metric of summary route.

R1(config-)# interface loopback0
R1(config-if)# bandwidth 1000000
R1#show ip eigrp topology
EIGRP-IPv4 Topology Table for AS(100)/ID(10.10.11.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 172.16.12.0/24, 1 successors, FD is 281600
        via Connected, Ethernet0/0
P 10.10.11.0/24, 1 successors, FD is 128256
        via Connected, Loopback1
P 10.10.13.0/24, 1 successors, FD is 435200
        via 172.16.12.2 (435200/409600), Ethernet0/0
P 172.16.23.0/24, 1 successors, FD is 307200
        via 172.16.12.2 (307200/281600), Ethernet0/0
P 10.10.10.0/23, 1 successors, FD is 128256
        via Summary (128256/0), Null0
P 10.10.10.0/24, 1 successors, FD is 130560
        via Connected, Loopback0

Gotcha: when you summarize the external EIGRP route, the summary network becomes internal EIGRP route.


I hope you enjoyed reading this article. Please feel free to leave any comment or feedback.

LinkedIn
Facebook
Facebook
Google+
https://netfixpro.com/eigrp-auto-and-manual-summarization/
RSS
Follow by Email

Ashutosh Patel

Ashutosh Patel is the Author and editor of netfixpro.com. He currently works as a Network Security Architect. Follow him on following social media to know more about him.

Leave a Reply

Your email address will not be published. Required fields are marked *

Show Buttons
Hide Buttons

Enjoy this article? Please spread the word :)